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Preface
SPOT.ON is a patented survey management software which allows operators to supervise, manage
and collect synchronized geographic position, video and virtually any other type of data in a survey
environment. Although SPOT.ON was originally designed for underwater use, it is ideal for recording
any type of georeferenced data.
SPOT.ON is used all over the world for pipe inspections, nuclear power plant cooling tunnel
inspections, survey planning, research and harbor control.
The US Navy Explosive Ordnance Disposal Divers use SPOT.ON to inspect ship hulls for
identification, documentation and disposal of improvised explosive devices. The Swedish Road and
Traffic Authority uses SPOT.ON to document roads and automatically flag problem areas for repair.
The Swedish Police have used SPOT.ON with video recorded from a helicopter to visualize sequences
of events following armored car robberies, allowed the court to easily understand the chain of evidence
during the trial.
Other customers include the German Water Police, the Finnish Navy, the Danish Navy and the
Swedish Coast Guard, not to mention countless research institutions, universities, port authorities,
dive operators and survey companies.
Collected data is connected to a track overlay on a drawing, map or chart. Any part of the recorded data
is instantly viewable and playable by simply clicking the track. Points of interest are automatically
presented in an automated report.
Of course, the full survey, including all video and other collected data, can be shared and played back
in the freely available SPOT.ON Viewer.
Due to a flexible and rapid development process custom modules can be deployed quickly. Simple
licensing terms allows installation on multiple computers and transfer of the license between them
without manual activation or an Internet connection.
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Chapter 1. SPOT.ON in Viewer/
Demonstration Mode
To use the recording, editing and reporting features of SPOT.ON, a valid Ocean Modules SPOT.ON
USB License Key must be inserted into one of the computer's USB ports. Without a valid License
Key installed SPOT.ON will only run in Viewer Mode which will allow recorded surveys which have
been exported for use in Viewer Mode to be played back.
In Viewer Mode, it is not possible to record new survey data, regenerate the report, change the map,
chart or drawing of the map view, change the pan/zoom of the map view, change the filtering or display
type of the track.
To use SPOT.ON in the freely available Viewer Mode please download and install SPOT.ON from
http://www.ocean-modules.com/spoton.html, and then follow the instructions to install and configure
x264vfw in the relevant section of this document.
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Chapter 2. System Requirements
All testing and verification is performed using Microsoft Windows 10 Pro 64-bit, which is the only
fully supported version of Microsoft Windows. SPOT.ON should run on all versions of Microsoft
Windows from Windows Vista SP2 and up as long as .NET Framework 4.6.2 has been installed, but
only limited support can be offered for unsupported versions of Microsoft Windows.
Please note that SPOT.ON cannot be run on any version of Microsoft Windows prior to Windows
Vista SP2 due to the lack of support for .NET Framework 4.6.

Caution
SPOT.ON is always run as a 32-bit process, and can therefore only use 32-bit DirectShow
filters. The reason for this is that required modules of the chart engine supplied by thirdparty developer are not yet available in 64-bit versions.
Hardware requirements vary depending on which modules are loaded, the required number of video
streams, recording quality, number of sensors, sensor data rate, survey length, etc. The Ocean Modules
rack-mounted PC equipped with the SPOT.ON Hardware Kit provides the most common interfaces
for analog video, HD-SDI video, sonar and serial data capture, and has been extensively tested
with various input sources. Ocean Modules strongly recommends using the rack-mounted PC and
SPOT.ON Hardware Kit for demanding applications.
At least one USB port must be available for the SPOT.ON USB License Key. Additional video capture
hardware, serial port interfaces and USB ports may be required depending on the type of data to be
acquired.

Warning
The SPOT.ON USB License Key represents the entire value of the SPOT.ON license.
A damaged or faulty USB Key can be repaired or replaced by Ocean Modules. Ocean
Modules is not responsible for replacing a lost or stolen USB Key, please ensure the
USB Key is adequately protected from loss and theft.
SPOT.ON will function in Viewer Mode if started without a USB License Key inserted into one of
the computer's USB ports. To use the full feature set, a valid USB License Key must be present.
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Chapter 3. Installation
1. Installers on the SPOT.ON USB License
Key memory area
All software required to run SPOT.ON, excluding device drivers specific to third-party data capture
devices, are supplied on the memory area of the SPOT.ON USB License Key.
The versions of the supplied software will be up to date at time of delivery of the SPOT.ON USB
License Key. However, more recent versions may be available for download, links to software sources
are provided in each section of this chapter.

2. Installing the x264 video codec
Before installing SPOT.ON, install the latest version of x264 Video for Windows, either from the
x264vfw installer supplied on the memory area of the SPOT.ON USB License Key, or download the
latest version from https://sourceforge.net/projects/x264vfw/.
Recent versions of the installer include both 32-bit and 64-bit versions of the video codec. Installing
both will not cause any problems, however, installing the 32-bit version is mandatory.
If the video codec has not been configured previously, open the the x264 Video for Windows
configuration application from the Windows Start menu.

Caution
Please note that if both 32-bit and 64-bit versions of the codec have been installed that
the two versions will be configured independently, using the Configure x264vfw and
Configure x264vfw64 applications respectively. Ensure the 32-bit version is correctly
configured for use with SPOT.ON.
The most important settings are "Zero Latency", which must be checked, and "Log Level", which must
be set to "None". Do not change any of the other default settings.
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It may be necessary to select a different "Preset" to suit the computer's capabilities. "Medium" provides
a reasonable compromise between quality, file size and processor requirements. If performance
problems persist choose a faster encoding.
Save changes before closing the application.

3. Installing SPOT.ON Survey System
Caution
It is important to install a version for which the SPOT.ON USB License Key is valid.
Typically a license will be valid for all revisions of a major version, i.e. a SPOT.ON 3.0
license will be valid for all SPOT.ON 3.x versions.
Surveys recorded or edited in a newer version of SPOT.ON cannot always be viewed
or edited in older versions of SPOT.ON. Therefore, it is also important to use the same
version of SPOT.ON for survey viewing purposes as the one used for recording or editing
the survey.
It is recommended to always upgrade to the latest version of SPOT.ON for which the
SPOT.ON USB License Key is valid.
Install SPOT.ON from the memory area of the SPOT.ON USB License Key, or download the
appropriate version from http://www.ocean-modules.com/spoton.html.
Accept the license agreement, check which fixes and features have been added since the last version
and launch SPOT.ON. The Ocean Modules SPOT.ON USB License Key does not need to be inserted
for installation, however, an installation which is started without a SPOT.ON USB License Key will
only function in SPOT.ON Viewer Mode.

4

Installation

4. Installing Microsoft .NET Framework
Recent versions of SPOT.ON require Microsoft .NET Framework version 4.5 or higher. If the
computer is not already equipped with an appropriate version of .NET Framework a message will be
displayed when SPOT.ON is started.
Ocean Modules recommends always using the most recent version of Microsoft .NET Framework.
If an Internet connection is present, the simplest way to acquire the most recent version of
Microsoft .NET Framework is to run Microsoft Windows Update.
If an Internet connection cannot be established, Microsoft .NET Framework can be installed from the
memory area of the SPOT.ON USB License Key. The most recent version of the Microsoft .NET
Framework Offline Installer can also be downloaded from https://www.microsoft.com/net/download.

5. Installing Optional C-MAP Charts
SPOT.ON features support for optional Jeppesen Marine C-MAP digital charts which can be used to
replace the standard vector world map. Please complete installation of SPOT.ON prior to installing
C-MAP as this will create the directory into which the chart data is to be placed.
To install C-MAP charts for use in SPOT.ON the following is required:
• Jeppesen C-MAP Professional+ chart database DVD or USB memory
• Jeppesen JeT Carmenta USB eToken Hardware License Key
• Jeppesen Carmenta .usr file
• Software installer for eToken PKI Client
• Software installer for C-MAP Runtime
Installation instructions:
1. Copy the Jeppesen Marine C-MAP Professional+ chart data folder named CM93_3 from the
supplied DVD or USB memory to C:\Maps\CM93_3. If Jeppesen Marine C-MAP charts were
purchased with SPOT.ON from Ocean Modules the chart data can be retrieved from the "Charts
and Maps" folder in the memory area of the SPOT.ON USB License Key.
2. Before continuing with application installation, log in as an Administrator, and ensure that
Windows User Account Control (UAC) is turned off in the user account settings. Once installation
and test is complete UAC can be enabled again.
3. Install the eToken PK Client using the Install eToken PKI Client 5.1 SP1.exe application from the
memory area of the SPOT.ON USB License Key. Accept the standard settings suggested during
the installation process. This software is required for the Jeppesen Marine USB eToken to function
correctly.
4. Once installed, run the Start eToken PKI Client application from the eToken folder in the Start
Menu.
5. Install the C-MAP Runtime using the Install C-MAP Runtime 5.5.msi application from the memory
area of the SPOT.ON USB License Key. Accept the standard settings suggested during the
installation process.
When prompted to insert the Jeppesen Marine USB eToken do so and click "Yes". If Windows
detects the USB eToken and asks to install drivers, choose "No".

5

Installation

When prompted for screen size, use the default value and click "OK". Screen calibration is not
required for SPOT.ON as the chart can be zoomed to the appropriate level depending on survey
requirements.
6. Run the C-Map Chart Manager from the C-Map Professional SDK Runtime folder in the Start
Menu.
7. From the Databases tab in the C-Map Chart Manager, click Register manually and select the
C:\Maps\CM93_3 folder. The new chart will appear as Professional+ in the list of registered
databases. Select the new database and click "Set as Default". A checkmark should appear to the
left of the Professional+ database.
8. From the Licenses tab in C-Map Chart Manager, click "Import from file" and select the .usr
file provided with the chart purchase. If Jeppesen Marine C-MAP charts were purchased with
SPOT.ON from Ocean Modules the .usr file can be retrieved from the "Charts and Maps" folder
in the memory area of the SPOT.ON USB License Key. If successful, the License list will show
the zones and areas for which the installation is now licensed. C-Map Chart Manager can now be
closed, using the "Close" button.
SPOT.ON can now be started and configured to use C-MAP according to the "Charts" section of this
manual.

Note
To increase performance under certain conditions some zoom levels of the C-MAP chart
have been disabled.
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Chapter 4. Creating a GeoTIFF
Download and Install Quantum GIS if it is not already installed. Quantum GIS can be downloaded
free of charge from http://www.qgis.org. This guide is based on Quantum GIS 1.7.4-Wroclaw for
Windows, but instructions for more recent versions or other operating systems should be similar.
Open the Georeferencer plugin by clicking on the Georeferencer icon or choose Plugins ->
Georeferences -> Georeferencer in the menu.

Open the map image you want to convert to a geotiff by clicking the Open raster icon or choose File
-> Open raster in the menu.

Georeferences will ask you what CRS (Coordinate Reference System) you want. You will typically
want to use WGS 84, i.e., the reference system used by GPS.
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Creating a GeoTIFF

Add at least two points (coordinates) by first selecting the Add point tool and the clicking on points
on the map with known coordinates. Notice that X-coordinates comes before Y-coordinates which is
the reverse compared for example coordinates taken from Google maps. The points in the example
image is the two red dots on the map.

Open Transformation settings by clicking the transformation settings icon or or choose Settings ->
Transformation settings in the menu.
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Creating a GeoTIFF

Choose your destination GeoTIFF file as Output raster. We recommend setting Target SRS to
EPSG:4326, i.e., WGS 84.

Generate the GeoTIFF by clicking Start georeferencing icon or choose File -> Start georeferencing
in the menu.

Now you have a GeoTIFF image that can be used in SPOT.ON.
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